Commit 6b7ab3a1 authored by M. Haseeb's avatar M. Haseeb

ENA-3950

- updated readtools.
parent d7a9644f
......@@ -11,7 +11,7 @@ plugins {
apply plugin: 'io.spring.dependency-management'
group = 'uk.ac.ebi.ena.webin-cli'
version = '3.1.0'
version = '3.2.0'
sourceCompatibility = '1.8'
targetCompatibility = '1.8'
......@@ -75,10 +75,10 @@ task printWebinTestCredentials {
}
dependencies {
implementation( 'uk.ac.ebi.ena.webin-cli:webin-cli-validator:1.0.9' )
implementation( 'uk.ac.ebi.ena.webin-cli:webin-cli-validator:1.0.9.1' )
implementation( 'uk.ac.ebi.ena.sequence:sequencetools:2.0.86' )
implementation( 'uk.ac.ebi.ena.txmbtools:txmbtools:1.0.3' )
implementation( 'uk.ac.ebi.ena:readtools:1.4.0' )
implementation( 'uk.ac.ebi.ena:readtools:1.5.0' )
implementation( 'org.springframework.boot:spring-boot-starter' )
implementation( 'org.springframework.boot:spring-boot-starter-web' ) {
exclude group: 'org.springframework.boot', module: 'spring-boot-starter-tomcat'
......
......@@ -102,7 +102,7 @@ public class ReadsValidationTest {
.isInstanceOf(WebinCliException.class)
.hasMessage("");
new ReportTester(executor).textInFileReport("invalid.fastq.gz", "does not match FASTQ regexp");
new ReportTester(executor).textInFileReport("invalid.fastq.gz", "Sequence header must start with @");
}
@Test
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment