Unverified Commit 0abc367d authored by Andrey Azov's avatar Andrey Azov Committed by GitHub
Browse files

Update dependencies (#525)

parent 1238f616
Pipeline #179282 passed with stages
in 4 minutes and 19 seconds
This diff is collapsed.
......@@ -31,24 +31,24 @@
"coverage": "jest --coverage"
},
"dependencies": {
"@apollo/client": "3.3.19",
"@apollo/client": "3.3.21",
"@loadable/component": "5.15.0",
"@loadable/server": "5.15.0",
"@reduxjs/toolkit": "1.5.1",
"@sentry/browser": "6.4.1",
"@reduxjs/toolkit": "1.6.1",
"@sentry/browser": "6.10.0",
"classnames": "2.3.1",
"comlink": "4.3.1",
"connected-react-router": "6.9.1",
"core-js": "3.12.1",
"core-js": "3.15.2",
"cross-fetch": "3.1.4",
"d3": "6.7.0",
"dotenv": "10.0.0",
"ensembl-genome-browser": "https://raw.githubusercontent.com/Ensembl/ensembl-genome-browser-assets/master/assets-80f51620ed443c640cdfd6b5aebd505b.tar.gz",
"express": "4.17.1",
"graphql": "15.5.0",
"http-proxy-middleware": "1.1.1",
"graphql": "15.5.1",
"http-proxy-middleware": "2.0.1",
"lodash": "4.17.21",
"query-string": "7.0.0",
"query-string": "7.0.1",
"react": "17.0.2",
"react-cookie": "4.0.3",
"react-dom": "17.0.2",
......@@ -57,113 +57,114 @@
"react-redux": "7.2.4",
"react-router": "5.2.0",
"react-router-dom": "5.2.0",
"react-spring": "9.1.2",
"react-spring": "9.2.4",
"redux": "4.1.0",
"redux-observable": "2.0.0-rc.1",
"rxjs": "7.1.0",
"rxjs": "7.2.0",
"typesafe-actions": "5.1.0",
"what-input": "5.2.10"
},
"devDependencies": {
"@babel/core": "7.14.3",
"@babel/plugin-transform-modules-commonjs": "7.14.0",
"@babel/preset-env": "7.14.2",
"@babel/preset-react": "7.13.13",
"@babel/preset-typescript": "7.13.0",
"@babel/core": "7.14.8",
"@babel/plugin-transform-modules-commonjs": "7.14.5",
"@babel/preset-env": "7.14.8",
"@babel/preset-react": "7.14.5",
"@babel/preset-typescript": "7.14.5",
"@loadable/babel-plugin": "5.13.2",
"@loadable/webpack-plugin": "5.15.0",
"@storybook/addon-essentials": "6.2.9",
"@storybook/addons": "6.2.9",
"@storybook/builder-webpack5": "6.2.9",
"@storybook/react": "6.2.9",
"@storybook/theming": "6.2.9",
"@storybook/addon-essentials": "6.3.5",
"@storybook/addons": "6.3.5",
"@storybook/builder-webpack5": "6.3.5",
"@storybook/manager-webpack5": "6.3.5",
"@storybook/react": "6.3.5",
"@storybook/theming": "6.3.5",
"@svgr/webpack": "5.5.0",
"@testing-library/jest-dom": "5.12.0",
"@testing-library/react": "11.2.7",
"@testing-library/user-event": "13.1.9",
"@testing-library/jest-dom": "5.14.1",
"@testing-library/react": "12.0.0",
"@testing-library/user-event": "13.2.0",
"@types/classnames": "2.3.1",
"@types/compression-webpack-plugin": "6.0.5",
"@types/copy-webpack-plugin": "8.0.0",
"@types/css-minimizer-webpack-plugin": "1.3.0",
"@types/d3": "6.6.0",
"@types/express": "4.17.11",
"@types/faker": "5.5.5",
"@types/compression-webpack-plugin": "6.0.6",
"@types/copy-webpack-plugin": "8.0.1",
"@types/css-minimizer-webpack-plugin": "3.0.2",
"@types/d3": "7.0.0",
"@types/express": "4.17.13",
"@types/faker": "5.5.7",
"@types/http-proxy-middleware": "1.0.0",
"@types/jest": "26.0.23",
"@types/loadable__component": "5.13.3",
"@types/loadable__server": "5.12.5",
"@types/loadable__webpack-plugin": "5.7.2",
"@types/lodash": "4.14.170",
"@types/mini-css-extract-plugin": "1.4.3",
"@types/node": "15.6.0",
"@types/prettier": "2.2.3",
"@types/react": "17.0.6",
"@types/react-dom": "17.0.5",
"@types/react-redux": "7.1.16",
"@types/react-router-dom": "5.1.7",
"@types/react-router-hash-link": "2.4.0",
"@types/redux-mock-store": "1.0.2",
"@types/terser-webpack-plugin": "5.0.3",
"@types/webpack-dev-middleware": "4.1.3",
"@types/webpack-env": "1.16.0",
"@types/webpack-hot-middleware": "2.25.4",
"@types/webpack-node-externals": "2.5.1",
"@types/workbox-webpack-plugin": "5.1.6",
"@typescript-eslint/eslint-plugin": "4.24.0",
"@typescript-eslint/parser": "4.24.0",
"@types/jest": "26.0.24",
"@types/loadable__component": "5.13.4",
"@types/loadable__server": "5.12.6",
"@types/loadable__webpack-plugin": "5.7.3",
"@types/lodash": "4.14.171",
"@types/mini-css-extract-plugin": "2.0.1",
"@types/node": "16.4.1",
"@types/prettier": "2.3.2",
"@types/react": "17.0.15",
"@types/react-dom": "17.0.9",
"@types/react-redux": "7.1.18",
"@types/react-router-dom": "5.1.8",
"@types/react-router-hash-link": "2.4.1",
"@types/redux-mock-store": "1.0.3",
"@types/terser-webpack-plugin": "5.0.4",
"@types/webpack-dev-middleware": "5.0.1",
"@types/webpack-env": "1.16.2",
"@types/webpack-hot-middleware": "2.25.5",
"@types/webpack-node-externals": "2.5.2",
"@types/workbox-webpack-plugin": "5.1.8",
"@typescript-eslint/eslint-plugin": "4.28.4",
"@typescript-eslint/parser": "4.28.4",
"babel-core": "7.0.0-bridge.0",
"babel-jest": "26.6.3",
"babel-jest": "27.0.6",
"babel-loader": "8.2.2",
"babel-plugin-react-remove-properties": "0.3.0",
"compression-webpack-plugin": "8.0.0",
"compression-webpack-plugin": "8.0.1",
"connect-history-api-fallback": "1.6.0",
"copy-webpack-plugin": "9.0.0",
"css-loader": "5.2.5",
"css-minimizer-webpack-plugin": "3.0.0",
"dotenv-webpack": "7.0.2",
"eslint": "7.27.0",
"copy-webpack-plugin": "9.0.1",
"css-loader": "6.2.0",
"css-minimizer-webpack-plugin": "3.0.2",
"dotenv-webpack": "7.0.3",
"eslint": "7.31.0",
"eslint-config-prettier": "8.3.0",
"eslint-plugin-jest": "24.3.6",
"eslint-plugin-jest": "24.4.0",
"eslint-plugin-prettier": "3.4.0",
"eslint-plugin-react": "7.23.2",
"eslint-plugin-react": "7.24.0",
"eslint-plugin-react-hooks": "4.2.0",
"faker": "5.5.3",
"file-loader": "6.2.0",
"fork-ts-checker-webpack-plugin": "6.2.10",
"gh-pages": "3.1.0",
"html-webpack-plugin": "5.3.1",
"husky": "6.0.0",
"fork-ts-checker-webpack-plugin": "6.2.13",
"gh-pages": "3.2.3",
"html-webpack-plugin": "5.3.2",
"husky": "7.0.1",
"identity-obj-proxy": "3.0.0",
"image-webpack-loader": "7.0.1",
"jest": "26.6.3",
"jest": "27.0.6",
"jest-fetch-mock": "3.0.3",
"jest-transform-stub": "2.0.0",
"licence-manager": "git+https://github.com/Ensembl/ensembl-licence-manager.git#36b534d28ff26d345b4ba4da0cbc18e1e0f7a6b7",
"lint-staged": "11.0.0",
"mini-css-extract-plugin": "1.6.0",
"nodemon": "2.0.7",
"postcss": "8.3.0",
"postcss-loader": "5.3.0",
"lint-staged": "11.1.1",
"mini-css-extract-plugin": "2.1.0",
"nodemon": "2.0.12",
"postcss": "8.3.6",
"postcss-loader": "6.1.1",
"postcss-preset-env": "6.7.0",
"prettier": "2.3.0",
"prettier": "2.3.2",
"redux-mock-store": "1.5.4",
"rimraf": "3.0.2",
"sass": "1.34.0",
"sass-loader": "11.1.1",
"sass": "1.36.0",
"sass-loader": "12.1.0",
"source-map-loader": "3.0.0",
"style-loader": "2.0.0",
"style-loader": "3.2.1",
"stylelint": "13.13.1",
"stylelint-config-recommended-scss": "4.2.0",
"stylelint-scss": "3.19.0",
"stylelint-webpack-plugin": "2.1.1",
"stylelint-config-recommended-scss": "4.3.0",
"stylelint-scss": "3.20.1",
"stylelint-webpack-plugin": "3.0.1",
"ts-multipick": "1.0.0",
"ts-node": "9.1.1",
"typescript": "4.2.4",
"webpack": "5.37.1",
"ts-node": "10.1.0",
"typescript": "4.3.5",
"webpack": "5.46.0",
"webpack-bundle-analyzer": "4.4.2",
"webpack-cli": "4.7.0",
"webpack-cli": "4.7.2",
"webpack-dev-server": "4.0.0-beta.2",
"webpack-merge": "5.7.3",
"webpack-merge": "5.8.0",
"webpack-node-externals": "3.0.0",
"workbox-webpack-plugin": "6.1.5",
"worker-loader": "3.0.8"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment