Unverified Commit 48815be2 authored by Andrey Azov's avatar Andrey Azov Committed by GitHub
Browse files

Update dependencies (#259)

Also, remove the 'git add' command from the lint-staged config in package.json
parent 39ae56d6
Pipeline #61881 failed with stages
in 7 minutes and 15 seconds
This diff is collapsed.
......@@ -40,8 +40,7 @@
"stylelint"
],
"*.{scss,ts,tsx}": [
"prettier --write",
"git add"
"prettier --write"
]
},
"husky": {
......@@ -50,21 +49,21 @@
}
},
"dependencies": {
"@sentry/browser": "5.11.1",
"@sentry/browser": "5.12.4",
"classnames": "2.2.6",
"connected-react-router": "6.6.1",
"connected-react-router": "6.7.0",
"core-js": "3.6.4",
"d3": "5.15.0",
"dotenv": "8.2.0",
"ensembl-genome-browser": "https://raw.githubusercontent.com/Ensembl/ensembl-genome-browser-assets/master/assets-80f51620ed443c640cdfd6b5aebd505b.tar.gz",
"koa-proxy": "1.0.0-alpha.3",
"lodash": "4.17.15",
"query-string": "6.10.1",
"query-string": "6.11.0",
"react": "16.12.0",
"react-cookie": "4.0.3",
"react-dom": "16.12.0",
"react-ga": "2.7.0",
"react-redux": "7.1.3",
"react-redux": "7.2.0",
"react-router": "5.1.2",
"react-router-dom": "5.1.2",
"react-spring": "8.0.27",
......@@ -77,40 +76,40 @@
"what-input": "5.2.6"
},
"devDependencies": {
"@babel/core": "7.8.3",
"@babel/core": "7.8.4",
"@babel/plugin-proposal-class-properties": "7.8.3",
"@babel/plugin-proposal-nullish-coalescing-operator": "7.8.3",
"@babel/plugin-proposal-object-rest-spread": "7.8.3",
"@babel/plugin-proposal-optional-chaining": "7.8.3",
"@babel/plugin-syntax-dynamic-import": "7.8.3",
"@babel/plugin-transform-modules-commonjs": "7.8.3",
"@babel/preset-env": "7.8.3",
"@babel/preset-env": "7.8.4",
"@babel/preset-react": "7.8.3",
"@babel/preset-typescript": "7.8.3",
"@storybook/addon-actions": "5.3.6",
"@storybook/addon-notes": "5.3.6",
"@storybook/react": "5.3.6",
"@svgr/webpack": "5.0.1",
"@storybook/addon-actions": "5.3.13",
"@storybook/addon-notes": "5.3.13",
"@storybook/react": "5.3.13",
"@svgr/webpack": "5.1.0",
"@types/classnames": "2.2.9",
"@types/d3": "5.7.2",
"@types/enzyme": "3.10.4",
"@types/enzyme-adapter-react-16": "1.0.5",
"@types/enzyme": "3.10.5",
"@types/enzyme-adapter-react-16": "1.0.6",
"@types/faker": "4.1.9",
"@types/jest": "24.9.0",
"@types/jest": "25.1.3",
"@types/lodash": "4.14.149",
"@types/node": "13.1.7",
"@types/node": "13.7.4",
"@types/prettier": "1.19.0",
"@types/react": "16.9.17",
"@types/react-dom": "16.9.4",
"@types/react-redux": "7.1.6",
"@types/react": "16.9.22",
"@types/react-dom": "16.9.5",
"@types/react-redux": "7.1.7",
"@types/react-router-dom": "5.1.3",
"@types/react-router-hash-link": "1.2.1",
"@types/redux-mock-store": "1.0.1",
"@types/webpack-env": "1.15.0",
"@typescript-eslint/eslint-plugin": "2.16.0",
"@typescript-eslint/parser": "2.16.0",
"@types/redux-mock-store": "1.0.2",
"@types/webpack-env": "1.15.1",
"@typescript-eslint/eslint-plugin": "2.20.0",
"@typescript-eslint/parser": "2.20.0",
"babel-core": "7.0.0-bridge.0",
"babel-jest": "24.9.0",
"babel-jest": "25.1.0",
"babel-loader": "8.0.6",
"brotli-webpack-plugin": "1.1.0",
"compression-webpack-plugin": "3.1.0",
......@@ -119,27 +118,27 @@
"css-loader": "3.4.2",
"enzyme": "3.11.0",
"enzyme-adapter-react-16": "1.15.2",
"enzyme-to-json": "3.4.3",
"enzyme-to-json": "3.4.4",
"eslint": "6.8.0",
"eslint-config-prettier": "6.9.0",
"eslint-config-prettier": "6.10.0",
"eslint-plugin-prettier": "3.1.2",
"eslint-plugin-react": "7.18.0",
"eslint-plugin-react-hooks": "2.3.0",
"eslint-plugin-react": "7.18.3",
"eslint-plugin-react-hooks": "2.4.0",
"faker": "4.1.0",
"file-loader": "5.0.2",
"fork-ts-checker-webpack-plugin": "3.1.1",
"file-loader": "5.1.0",
"fork-ts-checker-webpack-plugin": "4.0.4",
"gh-pages": "2.2.0",
"html-webpack-plugin": "3.2.0",
"husky": "4.0.10",
"husky": "4.2.3",
"identity-obj-proxy": "3.0.0",
"image-webpack-loader": "6.0.0",
"jest": "24.9.0",
"jest": "25.1.0",
"jest-fetch-mock": "3.0.1",
"jest-transform-stub": "2.0.0",
"koa": "2.11.0",
"koa-connect": "2.0.1",
"koa-static": "5.0.0",
"lint-staged": "9.5.0",
"lint-staged": "10.0.7",
"mini-css-extract-plugin": "0.9.0",
"node-sass": "4.13.1",
"optimize-css-assets-webpack-plugin": "5.0.3",
......@@ -147,23 +146,23 @@
"postcss-preset-env": "6.7.0",
"prettier": "1.19.1",
"redux-mock-store": "1.5.4",
"rimraf": "3.0.0",
"rimraf": "3.0.2",
"robotstxt-webpack-plugin": "7.0.0",
"sass-loader": "8.0.2",
"source-map-loader": "0.2.4",
"style-loader": "1.1.2",
"stylelint": "13.0.0",
"stylelint-config-recommended-scss": "4.1.0",
"stylelint-scss": "3.13.0",
"stylelint-webpack-plugin": "1.2.1",
"terser-webpack-plugin": "2.3.2",
"typescript": "3.7.5",
"webpack": "4.41.5",
"style-loader": "1.1.3",
"stylelint": "13.2.0",
"stylelint-config-recommended-scss": "4.2.0",
"stylelint-scss": "3.14.2",
"stylelint-webpack-plugin": "1.2.3",
"terser-webpack-plugin": "2.3.5",
"typescript": "3.8.2",
"webpack": "4.41.6",
"webpack-bundle-analyzer": "3.6.0",
"webpack-cli": "3.3.10",
"webpack-dev-server": "3.10.1",
"webpack-cli": "3.3.11",
"webpack-dev-server": "3.10.3",
"webpack-merge": "4.2.2",
"workbox-webpack-plugin": "4.3.1"
"workbox-webpack-plugin": "5.0.0"
},
"browserslist": [
"> 1% and last 2 versions",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment