Commit 4cbb3f16 authored by Eduardo Sanz García's avatar Eduardo Sanz García
Browse files

chore: angular 7 real upgrade

parent 39e7566e
Pipeline #7471 passed with stage
in 5 minutes and 56 seconds
......@@ -4,7 +4,7 @@ root = true
[*]
charset = utf-8
indent_style = space
indent_size = 2
indent_size = 4
insert_final_newline = true
trim_trailing_whitespace = true
......
<a name="1.0.0-beta.4"></a>
# [1.0.0-beta.4](https://gitlab.ebi.ac.uk/tools-glue/ng-ebi-authorization/compare/1.0.0-beta.3...1.0.0-beta.4) (2018-10-23)
### Features
* updated to angular version 7
<a name="1.0.0-beta.3"></a>
# [1.0.0-beta.3](https://gitlab.ebi.ac.uk/tools-glue/ng-ebi-authorization/compare/1.0.0-beta.2...1.0.0-beta.3) (2018-10-23)
### Features
* updated to angular version 7
* no additional features
<a name="1.0.0-beta.2"></a>
# [1.0.0-beta.2](https://gitlab.ebi.ac.uk/tools-glue/ng-ebi-authorization/compare/1.0.0-beta.1...1.0.0-beta.2) (2018-09-10)
......
......@@ -23,7 +23,7 @@ Angular version | ng-ebi-authorization version
--- | ---
>=5 <6 | <= angular-aap-auth@1.0.0-alpha.7 (deprecated)
>=6 <7 | >= angular-aap-auth@1.0.0-alpha.8 (deprecated) or ng-ebi-authorization@1.0.0-beta.1
>=7 <8 | >= ng-ebi-authorization@1.0.0-beta.3
>=7 <8 | >= ng-ebi-authorization@1.0.0-beta.4
ng-ebi-authorization is an updated version of angular-aap-auth.
......
{
"name": "ng-ebi-authorization",
"version": "1.0.0-beta.3",
"version": "1.0.0-beta.4",
"license": "Apache-2.0",
"scripts": {
"ng": "ng",
......@@ -33,29 +33,29 @@
},
"dependencies": {},
"peerDependencies": {
"@angular/core": ">=6 <7",
"@angular/core": ">=7 <8",
"@auth0/angular-jwt": "^2.0.0",
"rxjs": ">=6 <7"
},
"devDependencies": {
"@angular-devkit/build-angular": "~0.8.3",
"@angular/cli": "6.2.3",
"@angular/common": "6.1.8",
"@angular/compiler": "6.1.8",
"@angular/compiler-cli": "6.1.8",
"@angular/core": "6.1.8",
"@angular/language-service": "6.1.8",
"@angular/platform-browser": "6.1.8",
"@angular/platform-browser-dynamic": "6.1.8",
"@angular-devkit/build-angular": "~0.10.0",
"@angular/cli": "7.0.2",
"@angular/common": "7.0.0",
"@angular/compiler": "7.0.0",
"@angular/compiler-cli": "7.0.0",
"@angular/core": "7.0.0",
"@angular/language-service": "7.0.0",
"@angular/platform-browser": "7.0.0",
"@angular/platform-browser-dynamic": "7.0.0",
"@auth0/angular-jwt": "^2.0.0",
"@types/jasmine": "~2.8.8",
"@types/jasminewd2": "~2.0.3",
"@types/node": "~10.10.1",
"@types/node": "~10.12.0",
"codelyzer": "^4.4.4",
"core-js": "^2.5.7",
"jasmine-core": "^3.2.1",
"jasmine-spec-reporter": "~4.2.1",
"karma": "~3.0.0",
"karma": "~3.1.0",
"karma-chrome-launcher": "~2.2.0",
"karma-coverage-istanbul-reporter": "^2.0.4",
"karma-jasmine": "~1.1.2",
......@@ -65,9 +65,10 @@
"protractor": "~5.4.1",
"rxjs": "^6.3.2",
"ts-node": "~7.0.1",
"tsickle": "^0.33.0",
"tslint": "~5.11.0",
"typedoc": "^0.12.0",
"typescript": ">=2.7.2 <2.10",
"typedoc": "^0.13.0",
"typescript": "3.1.3",
"zone.js": "^0.8.26"
}
}
......@@ -270,9 +270,14 @@ export class AuthService {
return;
}
this._storageUpdater(event.data);
// I don't know how to type guard event.source
// This doesn't work
// if (event.source instanceof Window) {
if (event.source) {
event.source.close();
(event.source as Window).close();
}
this._updateUser();
// Triggers updating other windows
......
......@@ -43,7 +43,6 @@
/** Evergreen browsers require these. **/
// Used for reflect-metadata in JIT. If you use AOT (and only Angular decorators), you can remove.
import 'core-js/es7/reflect';
/**
......
This diff is collapsed.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment