Commit 032d798e authored by Matthieu Muffato's avatar Matthieu Muffato
Browse files

End of support for older Perl versions

Enabled testing on 5.26, as per our announcement. Hopefully it will work !
parent eb200cbb
language: "perl"
perl:
- "5.10"
- "5.14"
- "5.26"
env:
- COVERALLS=true
......@@ -30,11 +30,11 @@ notifications:
slack:
secure: "fbxQ+yuUAKKI10MUmNeCUbLqmVoOHUhGdM2KetqT5DmSn2rHxb099040Ira2tBYmUEPb5QvIMfPZ1xgS27he4xsZIpvOLsd1Or9OOL8XqyeTLcZ/IG4rpky0ehltVXs3s4ClM+YXwCHIoR2FwVghLVn6znmRkYm3TreSDtEUC2o="
# Get the matrix to only build coveralls support when on 5.10
# Get the matrix to only build coveralls support when on 5.14
matrix:
exclude:
- perl: "5.10"
env: COVERALLS=false
- perl: "5.14"
env: COVERALLS=true
- perl: "5.26"
env: COVERALLS=false
......@@ -2,7 +2,7 @@
1. Download and install the necessary external software:
1.1. Perl 5.10 or higher, since eHive code is written in Perl
1.1. Perl 5.14 or higher, since eHive code is written in Perl
see http://www.perl.com/download.csp
......
......@@ -12,7 +12,7 @@
eHive system depends on the following components that you may need to download and install first:
<ol>
<li>Perl 5.10 <a href=http://www.perl.org/get.html>or higher</a></li>
<li>Perl 5.14 <a href=http://www.perl.org/get.html>or higher</a></li>
<li>A database engine of your choice. eHive keeps its state in a database, so you will need
<ol>
<li>a server installed on the machine where you want to maintain the state of your pipeline(s) and</li>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment